Wednesday, February 26

IOS Hardware


Configure IOS Hardware transcoding resources in order to meet following Requirements.

1) Site B IP phones should be able to call ICD Route point number 2400 using    G729 codec.
2) HQ and Site B IP phones should be able to call Cisco Unity Express       
     voicemail pilot using G729 codec.


On HQ Router



Check SCCP configuration.
R1#sh runn | b sccp
sccp local FastEthernet0/0.102
sccp ccm 142.100.64.11 identifier 2 priority 2 version 7.0
sccp ccm 142.100.64.12 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface FastEthernet0/0.102
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 3 register hq-cfb
associate profile 2 register hq-mtp
!
dspfarm profile 3 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
dspfarm profile 2 mtp
codec g729r8
codec pass-through
rsvp
maximum sessions software 4
associate application SCCP
Configure transcoding resources.
R1(config)#dspfarm profile 1 transcode
R1(config-dspfarm-profile)#codec g711ulaw
R1(config-dspfarm-profile)#codec g729r8
R1(config-dspfarm-profile)#maximum sessions 7
R1(config-dspfarm-profile)#associate application SCCP
R1(config-dspfarm-profile)#no shutdown
Register transcoder resources in SCCP CCM group.
R1(config)#sccp ccm group 1
R1(config-sccp-ccm)#associate profile 1 register hq-xcoder

Now we need to Check configuration.

R1#show dspfarm profile
Dspfarm Profile Configuration
Profile ID = 1, Service = TRANSCODING, Resource ID = 1
Profile Description :
Profile Service Mode : Non Secure
Profile Admin State : UP
Profile Operation State : ACTIVE IN PROGRESS
Application : SCCP Status : ASSOCIATION IN PROGRESS
Resource Provider : FLEX_DSPRM Status : UP
Number of Resource Configured : 7
Number of Resource Available : 7
Codec Configuration
Codec : g711ulaw, Maximum Packetization Period : 30
Codec : g711alaw, Maximum Packetization Period : 30
Codec : g729ar8, Maximum Packetization Period : 60
Codec : g729abr8, Maximum Packetization Period : 60
Codec : g729r8, Maximum Packetization Period : 60
On Site C Router

Now we need to check the  SCCP configuration.

R3#sh runn | b sccp
sccp local Vlan502
sccp ccm 142.100.64.11 identifier 2 priority 2 version 7.0
sccp ccm 142.100.64.12 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface Vlan502
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register sc-mtp
!
dspfarm profile 2 mtp
codec g729r8
codec pass-through
rsvp
maximum sessions software 4
associate application SCCP

Configure transcoding resources.

R3(config)#dspfarm profile 1 transcode
R3(config-dspfarm-profile)#codec g711ulaw
R3(config-dspfarm-profile)#codec g729r8
R3(config-dspfarm-profile)#maximum sessions 3
R3(config-dspfarm-profile)#associate application SCCP
R3(config-dspfarm-profile)#no shutdown

We have to configure 3 transcoding sessions here. The reason for this we have 3 CTI ports for the CUE (and they use G711ulaw) and they ask for CUE ports specifically.

Register transcoder resources in SCCP CCM group.

R1(config)#sccp ccm group 1
R1(config-sccp-ccm)#associate profile 1 register sc-xcoder

On CUCM side
Register the transcoders for HQ and Site C (Cisco Unified CM Administration→Media Re-sources→Transcoder).


HQ Transcoder


Site C Transcoder

Add the transcoders to HQ and Site C media resource groups (Cisco Unified CM Administration→Media Resources→ Media Resource Group).


IOS-HQ Media Resource Group



Site C Media Resource Group

Call to 2400 from Site B IP Phone and check on R1 if transcoder is used.

R1#sh sccp connections

sess_id conn_id stype mode codec sport rport ripaddr
33555467 33554592 xcode sendrecv g711u 19412 24576 142.100.64.14
33555467 33554591 xcode sendrecv g729ab 17226 24628 142.102.65.30
Total number of active session(s) 1, and connection(s) 2
Call to 2400 from Site C IP Phone and check on R1 if transcoder is used.

R1#sh sccp connections

sess_id conn_id stype mode codec sport rport ripaddr
33556435 33554446 xcode sendrecv g711u 16556 24576 142.100.64.14
33556435 33554445 xcode sendrecv g729ab 17290 24072 142.102.66.12
Total number of active session(s) 1, and connection(s) 2

CCIE Voice (R1)

R1 final configuration.
Indianexperts#sh runn
Building configuration...
Current configuration : 4920 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Indianexperts
!
boot-start-marker
boot system flash:c2800nm-ipvoice_ivs-mz.124-24.T5.bin
boot-end-marker
card type t1 0 0
logging message-counter syslog
enable password cisco
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
ip source-route
!
!
ip cef
!
!
no ip domain lookup
ip domain name cisco.com
no ipv6 cef
multilink bundle-name authenticated

!
isdn switch-type primary-ni

!
voice-card 0
dsp services dspfarm

!
archive
log config
hidekeys

!
controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp
!
controller T1 0/0/1
shutdown
cablelength long 0db

!
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority 48
compress header ip rtp
class AutoQoS-VoIP-Control-Trust
bandwidth 16000
class class-default
fair-queue
!
interface Loopback0
ip address 142.1.64.254 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 142.100.64.254 255.255.255.0
!
interface FastEthernet0/0.102
encapsulation dot1Q 102
ip address 142.102.64.254 255.255.255.0
ip helper-address 142.100.64.11
!
interface FastEthernet0/0.202
encapsulation dot1Q 202 native
ip address 142.202.64.254 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn negotiate-bchan
isdn outgoing display-ie
no cdp enable
!
interface Serial0/1/0
no ip address
encapsulation frame-relay IETF
frame-relay traffic-shaping
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial0/1/0.101 point-to-point
description --To R2—
bandwidth 384
ip address 142.65.64.1 255.255.255.252
snmp trap link-status
frame-relay interface-dlci 201
class AutoQoS-FR-Se0/1/0-201
auto qos voip trust
!
interface Serial0/1/0.201 point-to-point
description --To R3—
bandwidth 1544
ip address 142.66.64.1 255.255.255.252
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 202
class HQ-SC
ip rsvp bandwidth 112
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 142.202.64.254
log-adjacency-changes
network 142.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
!
!
map-class frame-relay AutoQoS-FR-Se0/1/0-201
frame-relay cir 364800
frame-relay bc 3648
frame-relay be 0
frame-relay mincir 364800
frame-relay fragment 480
service-policy output AutoQoS-Policy-Trust
!
map-class frame-relay HQ-SC
frame-relay cir 1466800
frame-relay bc 14668
frame-relay be 0
frame-relay mincir 1466800
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33334 cbQosCMDropBitRate.418.3168001 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
voice-port 0/0/0:23
!
ccm-manager switchback immediate
ccm-manager redundant-host 142.100.64.11
ccm-manager mgcp
!
mgcp
mgcp call-agent 142.100.64.12 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp ip qos dscp cs3 signaling
mgcp bind control source-interface FastEthernet0/0.102
mgcp bind media source-interface FastEthernet0/0.102
mgcp behavior g729-variants static-pt
!
mgcp profile default
!
sccp local FastEthernet0/0.102
sccp ccm 142.100.64.11 identifier 2 version 7.0
sccp ccm 142.100.64.12 identifier 1 version 7.0
sccp
!
sccp ccm group 1
bind interface FastEthernet0/0.102
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register hq-rsvp
associate profile 3 register hq-conf
associate profile 1 register hq-xcode
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 7
associate application SCCP
!
dspfarm profile 3 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
dspfarm profile 2 mtp
codec g729r8
codec pass-through
rsvp
maximum sessions software 4
associate application SCCP
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler allocate 20000 1000
ntp source Loopback0
ntp server 157.26.1.100
en

CCIE Voice Switch

SW1#sh run
Building configuration...
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
enable password cisco
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
switch 1 provision ws-c3750g-48ts
system mtu routing 1998
vtp domain ccievoice.com
vtp mode transparent
ip subnet-zero
no ip domain-lookup
ip domain-name ccievoice.com
!
!
mls qos map policed-dscp 24 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 100
name hq-server
!
vlan 102
name hq-voice
!
vlan 202
name hq-data
!
class-map match-any CUPC-SIG
match access-group name SIG
class-map match-any CUPC-RTP
match access-group name RTP
!
policy-map CUPC-OUT
class CUPC-RTP
set dscp ef
class CUPC-SIG
set dscp cs3
police 32000 8000 exceed-action policed-dscp-transmit
class class-default
trust dscp
!
interface GigabitEthernet1/0/1
description connect-to-hq-router
switchport trunk encapsulation dot1q
switchport trunk native vlan 202
switchport mode trunk
mls qos trust dscp
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
description CUCM PUB, SUB, CUC, CUPS
switchport access vlan 100
switchport mode access
mls qos trust dscp
!
interface GigabitEthernet1/0/4
description UCCX, TEST Machine
switchport access vlan 100
switchport mode access
service-policy input CUPC-OUT
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
description HQ Phone 1
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
!
interface GigabitEthernet1/0/14
description HQ Phone 2
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
!
interface GigabitEthernet1/0/15
description HQ Phone 3
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
description connect-to-pstn-router
switchport mode access
switchport voice vlan 100
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/24
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 142.100.64.250 255.255.255.0
!
ip default-gateway 142.100.64.254
ip classless
ip route 0.0.0.0 0.0.0.0 142.100.64.254
ip http server
ip http secure-server
!
!
!
control-plane
!
!
ip access-list extended RTP
permit udp any any range 16384 16424
ip access-list extended SIG
permit tcp any any eq www
permit tcp any any eq 443
permit tcp any any eq 993
permit tcp any any eq 7993
permit tcp any any eq 143
permit tcp any any eq 5060
permit udp any any eq 5060
permit tcp any any eq 389
permit udp any any eq tftp
permit tcp any any eq 2748
!
!
line con 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password cisco
login
line vty 5 15
exec-timeout 0 0
password cisco
login
!
ntp clock-period 36028508
ntp server 142.1.64.254
end

CCIE Voice (R2)


runn
Building configuration...
Current configuration : 6953 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Indianexperts
!
boot-start-marker
boot-end-marker
!
card type t1 1 0
logging message-counter syslog
enable password cisco
!
no aaa new-model
memory-size iomem 5
clock timezone CST -6
clock summer-time CDT recurring
network-clock-participate slot 1
network-clock-select 1 T1 1/0/0
!
voice-card 0
no dspfarm

!
voice-card 1
dspfarm
!
ip source-route
!
!
ip cef
!
!
no ip domain lookup
ip domain name cisco.com
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
voice service voip
allow-connections h323 to h323
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class h323 1
h225 timeout tcp establish 3
h225 timeout setup 3
!
voice translation-rule 1
rule 1 /^.*\(3...\)$/ /\1/
!
voice translation-rule 2
rule 1 /^3...$/ /972303&/ type any national plan any isdn
!
voice translation-rule 3
rule 1 /^3...$/ /303&/ type any subscriber plan any isdn
rule 2 /^2...$/ /408202&/ type any national plan any isdn
!
voice translation-rule 4
rule 1 /^3...$/ /972303&/ type any national plan any isdn
rule 2 /^2...$/ /408202&/ type any national plan any isdn
!
voice translation-rule 5
rule 1 /^3...$/ /+1972303&/ type any international plan any isdn
rule 2 /^2...$/ /+1408202&/ type any international plan any isdn
!
voice translation-rule 10
rule 1 /^5252222$/ /95252222/
!
voice translation-rule 12
rule 1 // // type any unknown plan any isdn
!
voice translation-rule 13
rule 1 // // type any subscriber plan any isdn
!
voice translation-rule 14
rule 1 // // type any national plan any isdn
!
voice translation-rule 15

rule 1 // // type any international plan any isdn
!
voice translation-profile emg
translate calling 2
translate called 12
!
voice translation-profile in
translate called 1
!
voice translation-profile int
translate calling 5
translate called 15
!
voice translation-profile mva
translate calling 10
!
voice translation-profile nat
translate calling 4
translate called 14
!
voice translation-profile sub
translate calling 3
translate called 13

!
application
service mvapub http://142.100.64.11:8080/ccmivr/pages/IVRMainpage.vxml
!
service mvasub http://142.100.64.12:8080/ccmivr/pages/IVRMainpage.vxml
!
archive

log config
hidekeys
!
!
controller T1 1/0/0
framing esf
linecode b8zs
cablelength long 0db
pri-group timeslots 1-24
!
!
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority 48
compress header ip rtp
class AutoQoS-VoIP-Control-Trust
bandwidth 16
class class-default
fair-queue
!
interface Loopback0
ip address 142.1.65.254 255.255.255.0
!
interface vlan 302
ip address 142.102.65.254 255.255.255.0

ip helper-address 142.100.64.11
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 142.102.65.254
!
interface vlan 402
ip address 142.202.65.254 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1/0
switchport trunk native vlan 402
switchport mode trunk
switchport voice vlan 302
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport trunk native vlan 402
switchport mode trunk
switchport voice vlan 302
spanning-tree portfast
!
interface Serial0/0/0
no ip address
encapsulation frame-relay

frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
snmp trap link-status
!
interface Serial0/0/0.101 point-to-point
description --To HQ-RTR—
bandwidth 384
ip address 142.65.64.2 255.255.255.252
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 101
class SB-HQ
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial1/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn negotiate-bchan
isdn outgoing display-ie
isdn outgoing ie redirecting-number
no cdp enable
!
router ospf 1
router-id 142.202.65.254
log-adjacency-changes
network 142.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
!
no ip http server

!
map-class frame-relay SB-HQ
frame-relay cir 364800
frame-relay bc 3648
frame-relay be 0
frame-relay mincir 364800
frame-relay fragment 480
service-policy output AutoQoS-Policy-Trust

!
control-plane

!
voice-port 1/0/0:23
translation-profile incoming in
!
dial-peer cor custom
name noint
name int
!
dial-peer cor list noint
member noint
!
dial-peer cor list all
member noint
member int
!
dial-peer voice 2 pots
incoming called-number .T
direct-inward-dial
!
dial-peer voice 1 voip
voice-class codec 1
incoming called-number .
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 3000 voip
destination-pattern 3...$
voice-class codec 1
voice-class h323 1
session target ipv4:142.100.64.12
dtmf-relay h245-alphanumeric
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 3001 voip
preference 1
destination-pattern 3...$
voice-class codec 1
voice-class h323 1
session target ipv4:142.100.64.11
dtmf-relay h245-alphanumeric
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 911 pots
corlist outgoing noint
translation-profile outgoing emg
destination-pattern 911$
port 1/0/0:23

forward-digits all
!
dial-peer voice 303 pots
corlist outgoing noint
translation-profile outgoing sub
destination-pattern 9[2-9]......$
port 1/0/0:23
!
dial-peer voice 91 pots
corlist outgoing noint
translation-profile outgoing nat
destination-pattern 91[2-9]..[2-9]......$
port 1/0/0:23
prefix 1
!
dial-peer voice 9011 pots
corlist outgoing all
translation-profile outgoing int
destination-pattern 9011T
port 1/0/0:23
prefix 011
!
dial-peer voice 2000 pots
corlist outgoing noint
translation-profile outgoing nat
destination-pattern 2...$
port 1/0/0:23
prefix 14082022
!
dial-peer voice 4000 pots
corlist outgoing noint
translation-profile outgoing int
destination-pattern 4...$
port 1/0/0:23
prefix 01185224044
!

dial-peer voice 3300 pots
translation-profile incoming mva
service mvapub
incoming called-number 3300
no digit-strip
!
dial-peer voice 3301 pots
translation-profile incoming mva
preference 1
service mvasub
incoming called-number 3300
no digit-strip
!
gateway
timer receive-rtp 1200
!
gatekeeper
shutdown
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
timeouts interdigit 6
ip source-address 142.102.65.254 port 2000
max-ephones 4
max-dn 8 octo-line preference 9
transfer-pattern .T
voicemail 2220
huntstop channel 1
call-forward pattern .T
call-forward busy 2220
call-forward noan 2220 timeout 20
moh music-on-hold.au
time-zone 8
time-format 24
cor incoming all default
cor incoming noint 1 3001 - 3001
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler allocate 20000 1000
ntp server 142.1.64.254
end

DHCP Pool


Add DHCP pool config.
R3(config)#ip dhcp pool scpool
R3(dhcp-config)#origin file flash:scpool.txt
R3(dhcp-config)#default-router 142.102.66.254
R3(dhcp-config)#option 150 ip 142.100.64.12 142.100.64.11
R3(config)#service dhcp
Check DHCP configuration on SC Router.
R3#sh ip dhcp database
URL : flash:scpool.dat
Read : Nov 12 2012 06:53 PM
Written : Never
Status : Last read succeeded. Bindings have been loaded in RAM.
Delay : 0 seconds
Timeout : 300 seconds
Failures : 0
Successesdir: 1
R3#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
142.102.66.11/24 0100.0b46.d9XX.XX Infinite Static
142.102.66.12/24 0100.0f23.22XX.XX Infinite Static

R3#sh ip dhcp bind
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name

142.102.66.11 0100.0f23.22XX.XX Infinite Automatic


Show scpool.db on the terminal and copy to notepad.
R3#more flash:scpool.db
*time* Sep 12 2012 10:14 PM
*version* 4
!IP address Type Hardware address Lease expiration VRF
142.102.66.11 id 0100.0f23.22XX.XX Infinite
142.102.66.12 id 0100.0b46.d9XX.XX Infinite
!IP address Type Hardware address Interface-name
!IP address Interface-name Lease expiration Server IP address Hardware address Vrf
*end*

Check if the IP Phones gets IP

CCIE Voice (Site Remote[R3])


service timestamps log datetime msec
no service password-encryption

hostname Indianexperts
boot-start-marker
boot-end-marker


logging message-counter syslog
enable password cisco

no aaa new-model
clock timezone HKT 8
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0

ip source-route
ip cef

ip dhcp pool scpool
origin file flash:scpool.dat
default-router 142.102.66.254
option 150 ip 142.100.64.12 142.100.64.12


no ip domain lookup
ip domain name cisco.com
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type primary-net5

voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip

logging message-counter syslog
enable password cisco

no aaa new-model
clock timezone HKT 8
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0

ip source-route
ip cef

ip dhcp pool scpool
origin file flash:scpool.dat
default-router 142.102.66.254
option 150 ip 142.100.64.12 142.100.64.12


no ip domain lookup
ip domain name ccievoice.com
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type primary-net5

voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol cisco


voice translation-rule 1
rule 1 /^.*\(4...\)$/ /\1/

voice translation-rule 2
rule 1 /^4...$/ /2404&/ type any subscriber plan any isdn

voice translation-rule 3
rule 1 /^4...$/ /2404&/ type any subscriber plan any isdn

voice translation-rule 5
rule 1 /^4...$/ /+8522404&/ type any international plan any isdn

voice translation-rule 10
rule 1 /\*\(400.\)$/ /\1/

voice translation-rule 12
rule 1 // // type any subscriber plan any isdn

voice translation-rule 13
rule 1 // // type any subscriber plan any isdn
voice translation-rule 15
rule 1 // // type any international plan any isdn


voice translation-profile cue
translate redirect-called 10

voice translation-profile emg
translate calling 2
translate called 12

voice translation-profile in
translate called 1

voice translation-profile int
translate calling 5
translate called 15

voice translation-profile sub
translate calling 3
translate called 13

voice-card 0
dsp services dspfarm

application
service app-b-acd-aa
param voice-mail 4220
paramspace english index 1
param max-time-call-retry 700
param service-name app-b-acd
param number-of-hunt-grps 1
param drop-through-option 1
paramspace english language en
param handoff-string app-b-acd-aa
param max-time-vm-retry 2
paramspace english location flash:
param aa-pilot 4000
param second-greeting-time 60
param drop-through-prompt _bacd_welcome.au
param call-retry-timer 15

service app-b-acd
param queue-len 2
param aa-hunt1 4500
param number-of-hunt-grps 1
param queue-manager-debugs 1

global
service alternate Default

archive
log config
hidekeys

controller E1 0/0/0
pri-group timeslots 1-12,16 service mgcp

interface Loopback0
ip address 142.1.66.254 255.255.255.0
ip ospf network point-to-point
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto

interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto

interface FastEthernet0/3/0
switchport trunk native vlan 602
switchport mode trunk
switchport voice vlan 502
spanning-tree portfast

interface FastEthernet0/3/1
switchport trunk native vlan 602
switchport mode trunk
switchport voice vlan 502
spanning-tree portfast

interface FastEthernet0/3/2

interface FastEthernet0/3/3

interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn negotiate-bchan
isdn sending-complete
isdn outgoing display-ie
no cdp enable

interface Serial0/1/0
no ip address
encapsulation frame-relay IETF
fair-queue 64 256 37
frame-relay lmi-type ansi
ip rsvp bandwidth

interface Serial0/1/0.201 point-to-point
description --To HQ-RTR--
ip address 142.66.64.2 255.255.255.252
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 102
ip rsvp bandwidth 112

interface Serial0/1/1
no ip address
shutdown
clock rate 2000000

interface Service-Engine1/0
ip unnumbered Loopback0
service-module ip address 142.1.66.253 255.255.255.0
service-module ip default-gateway 142.1.66.254

interface Vlan1
no ip address

interface Vlan502
ip address 142.102.66.254 255.255.255.0
ip helper-address 142.100.64.11

interface Vlan602
ip address 142.202.66.254 255.255.255.0

router ospf 1
router-id 142.202.66.254
log-adjacency-changes
network 142.0.0.0 0.255.255.255 area 0

ip forward-protocol nd
ip route 142.1.66.253 255.255.255.255 Service-Engine1/0


ip http server
ip http path flash:/gui
control-plane

voice-port 0/0/0:15
translation-profile incoming in

ccm-manager switchback immediate
ccm-manager fallback-mgcp
ccm-manager redundant-host 142.100.64.11
ccm-manager mgcp
ccm-manager music-on-hold

mgcp
mgcp call-agent 142.100.64.12 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp ip qos dscp cs3 signaling
mgcp bind control source-interface Vlan502
mgcp bind media source-interface Vlan502

mgcp behavior g729-variants static-pt
mgcp profile default

sccp local Vlan502
sccp ccm 142.100.64.12 identifier 1 version 7.0
sccp ccm 142.100.64.11 identifier 2 version 7.0
sccp

sccp ccm group 1
bind interface Vlan502
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register sc-rsvp
associate profile 1 register sc-xcoder

dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 3
associate application SCCP

dspfarm profile 2 mtp
codec g729r8
codec pass-through
rsvp
maximum sessions software 4
associate application SCCP

dial-peer cor custom
name noint
name int

dial-peer cor list noint
member noint

dial-peer cor list all
member noint
member int


dial-peer voice 1 pots
incoming called-number .T
direct-inward-dial

dial-peer voice 999 pots
corlist outgoing noint
translation-profile outgoing emg
destination-pattern 999$
clid strip name
port 0/0/0:15
forward-digits all

dial-peer voice 2404 pots
corlist outgoing noint
translation-profile outgoing sub
destination-pattern 9[1-8].......$
port 0/0/0:15

dial-peer voice 900 pots
corlist outgoing all
translation-profile outgoing int
destination-pattern 900T
port 0/0/0:15

dial-peer voice 4220 voip
translation-profile outgoing cue
destination-pattern ^4220$
session protocol sipv2
session target ipv4:142.1.66.253
incoming called-number 4
dtmf-relay sip-notify
codec g711ulaw
no vad

dial-peer voice 2000 pots
corlist outgoing noint
translation-profile outgoing int
destination-pattern 2...$
port 0/0/0:15
prefix 14082022

dial-peer voice 3000 pots
corlist outgoing noint
translation-profile outgoing int
destination-pattern 3...$
port 0/0/0:15
prefix 19723033

dial-peer voice 4000 pots
service app-b-acd-aa
incoming called-number 4000
no digit-strip

sip-ua
mwi-server ipv4:142.1.66.253 expires 3600 port 5060 transport udp unsolicited


gatekeeper
shutdown


telephony-service
srst mode auto-provision none
max-ephones 4
max-dn 8 preference 9
ip source-address 142.102.66.254 port 2000
timeouts interdigit 6
time-zone 43
voicemail 4220
mwi relay
max-conferences 8 gain -6
call-forward pattern .T
moh en_bacd_music_on_hold.au
web admin system name administrator password ccievoice
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 9
create cnf-files version-stamp 7960 Dec 16 2012 00:14:30


ephone-dn-template 1
call-forward busy 4220
call-forward noan 4220 timeout 20
mwi sip
huntstop channel 1


ephone-dn 1 octo-line
number 4001
description +85224044001
name SiteC Phone 1
preference 9
corlist incoming noint
ephone-dn-template 1


ephone-dn 2
number 4101
description 4101
name SiteC Phone 1
preference 9


ephone-dn 3 octo-line
number 4002
description +85224044002
name SiteC Phone 2
preference 9
ephone-dn-template 1


ephone-dn 4
number 4102
description 4102
name SiteC Phone 2
preference 9


ephone-dn 5
number *4001
preference 9
call-forward all 4220


ephone 1
mac-address ACAC.ACAC.ACAC
speed-dial 4 *4001 label "Xfer-to-VM"
button 1:1 2:2



ephone 2
mac-address ABAB.ABAB.ABAB
button 1:3 2:4
ephone-hunt 1 longest-idle
pilot 4500
list 4101, 4102
timeout 10, 10

line con 0
exec-timeout 0 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
exec-timeout 0 0
password cisco
login

scheduler allocate 20000 1000
ntp server 157.26.1.100
end

My CCIE#53599

My journey started in 2013 when I decided for a CCIE in voice. One never really knows what they are in for when starting down this r...